DRAINS Viewer installation and operation

DRAINS Viewer installation and operation

The DRAINS Viewer can be installed on a Microsoft Windows PC using the 'DrainsViewerSetup.exe' file obtainable from Watercom.

Once installed, the Viewer can be opened from the Start
 
menu by selecting Programs and then DrainsViewer. The Main Window will then open, and after you have closed the introductory message, will appear as shown below. 



If needed, Help can be called from the Help menu, or by pressing the F1 button.  Options in the View menu can be used to alter the view of the model.  If you are familiar with DRAINS you will find that the Viewer operates in the same way except that the model cannot be altered or run.

Initially the 
Viewer will display a blank space.  As in DRAINS, the operations of the Viewer are controlled from menus. Drainage systems are constructed from a set of named components (
pits, sub-catchments, pipes, overflow routes, channels, etc.), that are joined together as shown below.  The information associated with each component is set out in a property sheet that can be opened by right clicking on the component and selecting Edit Data from the pop-up menu.


Project menu. Once a model is run, the component names change to colour-coded values of peak flowrates running through the system and the levels of hydraulic grade lines (HGLs) at pits and nodes, as shown below.  Models can be saved with data and results intact, as a DRAINS .drn file.


To understand this more completely, you can view one of the demonstration examples that are installed along with the DRAINS Viewer in the folder C:\Program Files\Drains\LiteExamples. Files such as the file named Gymea ILSAX Example - Lite.drn shown in the above window, can be opened using the Open option in the DRAINS File menu. (Note that sometimes a blank screen appears when a model is loaded. The model can be located using the Index Sheet option in the View menu.)

The Gymea system, located in suburban Sydney, includes a background showing street and property boundaries imported from a CAD file.  Components can be inspected by opening the property sheets for the components, as shown above.  If Property Balloons is switched on in the View menu, the main properties of components can also be viewed in balloons that appear as the mouse pointer runs over them.

Data can also be inspected by exporting tables to a spreadsheet via the Windows clipboard, using options in the Edit menu.  Part of a table is shown below.